Połączenie dwóch routerów z wykorzystaniem kart HWIC-4SHDSL (routery 28xx, 38xx, 28xx).

Artykuł dotyczy kart HWIC-4SHDSL zainstalowanych w routerach 2851 oraz 3845, ale będzie działało we wszystkich modelach routerów serii 28xx, tylko proszę zwrócić uwagę na problemy z widocznością karty w 2811 (opis na końcu).

Problem:

Chcemy połączyć dwa routery kablem miedzianym z wykorzystaniem kart HWIC-4SHDSL.

Na potrzeby artykułu definiujemy:
1. router „GORNY” – strona CO
2. router „DOLNY” – strona CPE

Połączenie routerów kartami SHDSL.

Kolejną sprawą jest sposób połączenia. Mój przykład jest oparty o dwie karty HWIC G.SHDSL (4 port). Diagram połączeń jest pokazany poniżej dla dwóch rodzajów połączeń – przy wykorzystaniu 2 wtyczek RJ45 (2 pary na wtyk) lub standardowo 4 wtyczki RJ11 (1 para na wtyk). Sposób połączenia obu routerów jest 1 do 1.

Połączenie karty 4SHDSL przez 2xRJ11

Połączenie karty 4SHDSL przez 4xRJ11

Zakładamy, że warstwę fizyczną mamy za sobą, więc przechodzimy do konfiguracji.

———————————-
———————————-
Strona CO
———————————-
———————————-

GORNY(config)#controller SHDSL 0/0/0
GORNY(config-controller)#termination co
— domyślnie router ma terminowanie cpe, więc przy tej zmianie będzie chciał restartu —
GORNY(config-controller)#dsl-group 0 pairs 0 //definujemy grupę dsl, z którą kojarzymy ilość par (tutaj jedna para/linia nr 0 – patrz schemat połączeń)
GORNY(config-controller-dsl-group)#shdsl annex A-B
———- Dostępne prędkości dla karty 4SHDSL ———-
Grupa DSL z 1 parą
Annex A & B—192-2304 kbps
Annex F & G (32 TC-PAM)—768-5696 kbps
Annex F & G (16 TC-PAM)—2304-3840 kbps
Grupa DSL z 2 parami
Annex A & B—384-4608 kbps
Annex F & G (32 TC-PAM)—1536-11392 kbps
Annex F & G (16 TC-PAM)— 4608-7680 kbps
Grupa DSL z 3 parami
Annex A & B—576-6912 kbps
Annex F & G (32 TC-PAM)—2304-12288 kbps
Annex F & G (16 TC-PAM)— 6912-11520 kbps
Grupa DSL z 4 parami
Annex A & B—768-9216 kbps
Annex F & G (32 TC-PAM)—3072-16384 kbps
Annex F & G (16 TC-PAM)— 9216-15360 kbps
————————————————————————
GORNY(config-controller-dsl-group)#shdsl rate auto //korzystając z powyższej tabeli sami możemy dobrać przepływność, lub zdać się na negocjację automatyczną, co też uczyniliśmy

———————————-
———————————-
Strona CPE
———————————-
———————————-

DOLNY(config)#controller SHDSL 0/0/0
DOLNY(config-controller)#termination cpe
DOLNY(config-controller)#dsl-group 0 pairs 0
DOLNY(config-controller-dsl-group)#shdsl annex A-B
DOLNY(config-controller-dsl-group)#shdsl rate auto

Po chwili otrzymamy ładne komunikaty dotyczące podniesienia się grupy dsl nr 0:
%HWIC_SHDSL-5-DSLGROUP_UPDOWN: SHDSL 0/0/0 dsl-group(0) state changed to up.

oraz interfejsu ATM:
%LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0/0, changed state to up

W tym, momencie możemy sprawdzić już jaką prędkość wynegocjowały routery, jaki rodzaj terminowania (co/cpe), ilość wykorzystanych linii i czy interfejs jest podniesiony:
DOLNY#show controllers SHDSL brief

Controller SHDSL 0/0/0 is UP
Hardware is HWIC-4SHDSL, rev 2 on slot 0, hwic slot 0
Capabilities: IMA, M-pair, 2/4 wire, Annex A, B, F & G, CPE termination
cdb=0x675C1EE0, plugin=0x7032F56C, ds=0x675A7634 base=0x43800000
FPGA Version is REL.3.4.0, NIOSII FW:Ver 2.9, status Running
SDC-16i HW:Rev 1.2, status UP, FW:Ver 1.2-1.1.3__57, status Running
SDFE-4 HW:Rev 1.2, status UP, FW:Ver 1.1-1.5.2__001  , status Running
NIOSII Firmware image: System
SDC16i Firmware image: System
SDFE4  Firmware image: System
Number of pairs 4, number of groups configured 1
Ignored CLI cmds(0), Event buffer: in use(0), failed(0)
Group (0) info:
Type: 2-wire g.shdsl, status: UP
Interface: ATM0/0/0, hwidb: 0x675C1FDC, UTOPIA phy 0
Configured/active num links: 1/1, bit map: 0x1/0x1
Line termination: CPE, line mode: 2-wire, Annex-A-B, PMMS disabled
Line coding: 16-TCPAM, configured/actual rate: AUTO/2304 kbps
SHDSL wire-pair (0) is in DSL UP state
Group (1) is Not configured.

Pozostaje nam konfiguracja interfejsu ATM.

———————————-
———————————-
Strona CO
———————————-
———————————-

GORNY(config)#interface ATM 0/0/0.1 point-to-point
GORNY(config-subif)#pvc kanal_do_DOLNY 0/1 //VPI=0 i VCI=1, „kanal_do_DOLNY” to nasz opis
GORNY(config-if-atm-vc)#encapsulation aal5snap
GORNY(config-if-atm-vc)#cdp enable //włączamy obsługę protokołu CDP dla tego interfejsu
GORNY(config-subif)#no shutdown

GORNY(config)#interface ATM 0/0/0
GORNY(config-if)#no shutdown

———————————-
———————————-
Strona CPE
———————————-
———————————-

DOLNY(config)#interface ATM 0/0/0.1 point-to-point
DOLNY(config-subif)#pvc kanal_do_GORNY 0/1 //te same wartości VPI/VCI co strona CPE  !!!
DOLNY(config-if-atm-vc)#encapsulation aal5snap
DOLNY(config-if-atm-vc)#cdp enable
DOLNY(config-subif)#no shutdown

DOLNY(config)#interface ATM 0/0/0
DOLNY(config-if)#no shutdown

Teraz już widzimy (oczywiście po chwili) sąsiada w CDP:

DOLNY#show cdp neighbors
Capability Codes: R – Router, T – Trans Bridge, B – Source Route Bridge
S – Switch, H – Host, I – IGMP, r – Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
GORNY            ATM0/0/0.1         165          S I      2851      ATM0/0/0.1

—————————————————————
Ostatnim elementem jest takie skonfigurowanie routingu, aby wszystkie sieci strony CO były widziane po stronie CPE i na odwrót. Najprostszym rozwiązaniem jest skonfigurowanie EIGRP uwzględniając sieci na danym routerze oraz sieć z maską 30, która będzie stworzona na potrzeby interfejsu ATM0/0/0.1.

Zacznijmy od adresacji. Zakładamy, że posiadamy 2 różne sieci na routerach (interfejsy Loopback 0 i 1) oraz dokładamy dodatkową sieć na potrzeby ATM (maska 30 więc max. 2 hosty):

CO:
adres interfejsu Loopback0 10.0.0.1/24 (sieć 10.0.0.0/24)
adres interfejsu Loopback1 10.0.1.1/24 (sieć 10.0.1.0/24)
adres interfejsu ATM0/0/0.1 192.168.1.201/30 (sieć 192.168.1.200/30)

CPE:
adres iterfejsu Loopback0 20.0.0.1/24 (sieć 20.0.0.0/24)
adres interfejsu Loopback1 10.0.1.1/24 (sieć 20.0.1.0/24)
adres interfejsu ATM0/0/0.1 192.168.1.202/30 (sieć 192.168.1.200/30)

W tym miejscu należy się uwaga, proszę zwrócić uwagę, że oba interfejsy ATM0/0/0.1 są w tej samej sieci – jest to logiczne ponieważ tworzymy połączenie punkt – punkt. Dodatkową pułapką może być  adresacja interfejsów Lo0 i Lo1 – są to sieci klasy A, o czym należy pamiętać przy konfigurowaniu protokołu EIGRP (chodzi o wyłączenie autosumaryzacji, gdyż te sieci mają domyślnie maskę /8). U nas tego problemy nie ma, gdyż oba routery mają różne sieci nawet adresowaniu klasowym (10.x.x.x i 20.x.x.x), ale jakby ktoś chciał sobie rozdzielić takie sieci, bezwzględnie należy pamiętać o wyłączeniu sumaryzacji w EIGRP (no auto-summary w danym procesie).

No to zaczynamy:

———————————-
———————————-
Strona CO
———————————-
———————————-

GORNY(config)#interface loopback 0 //tworzymy interfejs Loopback 0
GORNY(config-if)#ip address 10.0.0.1 255.255.255.0
GORNY(config-if)#exit
GORNY(config)#interface loopback 1 //tworzymy interfejs Loopback 1
GORNY(config-if)#ip address 10.0.1.1 255.255.255.0
GORNY(config-if)#exit
GORNY(config)#interface ATM 0/0/0.1 point-to-point //przystępujemy do konfiguracji adresu ip dla ATM
GORNY(config-subif)#ip address 192.168.1.201 255.255.255.252
GORNY(config-subif)#^Z

———————————-
———————————-
Strona CPE
———————————-
———————————-

DOLNY(config)#interface loopback 0
DOLNY(config-if)#ip address 20.0.0.1 255.255.255.0
DOLNY(config-if)#exit
DOLNY(config)#interface loopback 1
DOLNY(config-if)#ip address 20.0.1.1 255.255.255.0
DOLNY(config-if)#exit
DOLNY(config)#interface ATM 0/0/0.1 point-to-point
DOLNY(config-subif)#ip address 192.168.1.202 255.255.255.252
DOLNY(config-subif)#^Z

Już mamy skonfigurowane interfejsy. Możemy je pingować w ramach urządzenia:

GORNY#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
GORNY#ping 10.0.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
GORNY#ping 192.168.1.201

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.201, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms
GORNY#

GORNY#ping 20.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.0.0.1, timeout is 2 seconds:
..
Success rate is 0 percent (0/2)
GORNY#ping 20.0.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.0.1.1, timeout is 2 seconds:
..
Success rate is 0 percent (0/2)
GORNY#ping 192.168.1.202

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.202, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

Ale mamy problem – ponieważ mimo, że pingujemy obie strony ATM, to sieci nie widzimy. Dlaczego, ponieważ nie skonfigurowaliśmy protokołu routingu. Zatem ostatnim elementem spinającym routery będzie routing. Zresztą doskonale to widać w tablicy routingu:

GORNY#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 2 subnets
C       10.0.0.0 is directly connected, Loopback0
C       10.0.1.0 is directly connected, Loopback1
192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.200 is directly connected, ATM0/0/0.1

Widać bezpośrednio sieć ATM (dlatego ją pingujemy), ale brak informacji o sieci CPE (20.0.x.x).

Zakładamy, że skorzystamy z EIGRP (numer procesu 1):

———————————-
———————————-
Strona CO
———————————-
———————————-

GORNY(config)#router eigrp 1
GORNY(config-router)#network 10.0.0.0 0.0.0.255 //uwaga na odwrotną maskę (= 255.255.255.0)
GORNY(config-router)#network 10.0.1.0 0.0.0.255
GORNY(config-router)#network 192.168.1.200 0.0.0.3 //to jest odwrotna maska dla 255.255.255.252
GORNY(config-router)#exit

———————————-
———————————-
Strona CPE
———————————-
———————————-

DOLNY(config)#router eigrp 1 //ten sam numer procesu !!!
DOLNY(config-router)#network 20.0.0.0 0.0.0.255
DOLNY(config-router)#network 20.0.1.0 0.0.0.255
DOLNY(config-router)#network 192.168.1.200 0.0.0.3
DOLNY(config-router)#exit

W tym momencie sąsiedztwo EIGRP zostało ustanowione:
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.1.201 (ATM0/0/0.1) is up: new adjacency

Teraz już elegancko widać w tablicy routingu wszystkie sieci, więc robota skończona.

GORNY#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

D    20.0.0.0/8 [90/1241856] via 192.168.1.202, 00:15:14, ATM0/0/0.1
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.0.0.0/24 is directly connected, Loopback0
D       10.0.0.0/8 is a summary, 00:15:14, Null0
C       10.0.1.0/24 is directly connected, Loopback1
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
D       192.168.1.0/24 is a summary, 00:15:14, Null0
C       192.168.1.200/30 is directly connected, ATM0/0/0.1

————————————————————————————-

Od tego momentu mamy pełnoprawne połączenie obu urządzeń sieciowych.

PS. Uwaga, karta HWIC-4SHDSL może nie być widoczna w routerze 2811, wtedy wymagana jest aktualizacja IOS. U mnie, mimo zapewnień CISCO, w wersji 12.4(11)T4 karta nie była rozpoznawana,  sytuację rozwiązała zmiana na wersję 12.4(15)T8.

Dodaj komentarz

Twój adres email nie zostanie opublikowany.

This site uses Akismet to reduce spam. Learn how your comment data is processed.